aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2022-02-22 16:14:26 +0100
committerElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2022-02-22 16:15:37 +0100
commit0582101ca0e07f5f9b62e2cc0be405f8e4bc2d7c (patch)
tree04263aee52fb03afd77531ddf200d0278d228f93 /setup.py
parentffd744478256fddd7250101591931b234c3eb483 (diff)
Skeleton of a project
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ca1e3a1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+from setuptools import setup, find_packages
+
+try:
+ with open("README.rst", 'r') as fp:
+ long_description = fp.read()
+except IOError:
+ print("Could not read README.rst, long_description will be empty.")
+ long_description = ""
+
+setup(
+ name='hazwaz',
+ version='0.0.1',
+ packages=find_packages(),
+ test_suite='tests',
+ install_requires=[],
+ python_requires='>=3',
+ # Metadata
+ author="Elena ``of Valhalla'' Grandi",
+ author_email='valhalla@trueelena.org',
+ description='write command line scripts',
+ long_description=long_description,
+ long_description_content_type='text/x-rst',
+ license='AGPLv3+',
+ keywords='cli',
+ url='https://hazwaz.trueelena.org/',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)', # noqa: E501
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Software Development :: User Interfaces',
+ ],
+ project_urls={
+ 'Source': '',
+ 'Documentation': '',
+ 'Tracker': '',
+ 'Mailing lists': '',
+ },
+)