aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..14d73cc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python3
+
+from setuptools import setup
+
+setup(
+ name='debdate',
+ version='0.20170714',
+ scripts=['debdate'],
+ install_requires=[
+ 'python-dateutil',
+ ],
+ author="Elena ``of Valhalla'' Grandi",
+ author_email="valhalla@trueelena.org",
+ description='Convert Gregorian dates to Debian Regnal dates',
+ url='http://git.trueelena.org/cgit.cgi/software/debdate/about/',
+ license='WTFPLv2',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: DFSG approved',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Topic :: Religion',
+ 'Topic :: Utilities',
+ ]
+)