summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2019-03-09 12:51:33 +0100
committerElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2019-03-09 12:51:33 +0100
commitfcd687b5d8abf51fe046b80afe5cd7d15ca880e2 (patch)
treeaacc41c3b19cd4dc60898752cee4d846eaa24eb1 /setup.py
parent80631460484e1507e1b7e684118a7ffda4dbe304 (diff)
improved metadata in setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 23 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 15a6502..b90ae02 100644
--- a/setup.py
+++ b/setup.py
@@ -1,26 +1,37 @@
from setuptools import setup, find_packages
+
+try:
+ with open("README.rst", 'r') as fp:
+ long_description = fp.read()
+except IOError:
+ print("Could not read README.rst, long_description will be empty.")
+ long_description = ""
+
setup(
name='lesana',
- version='0.3',
+ version='0.3.0.dev1',
packages=find_packages(),
scripts=['scripts/lesana'],
+ package_data={
+ '': ['*.yaml']
+ },
+ test_suite='tests',
+
install_requires=[
'guacamole',
# 'xapian >= 1.4',
'ruamel.yaml',
'jinja2',
],
-
- package_data={
- '': ['*.yaml']
- },
- test_suite='tests',
+ python_requires='>=3',
# Metadata
author="Elena ``of Valhalla'' Grandi",
author_email='valhalla@trueelena.org',
description='Manage collection inventories throught yaml files.',
+ long_description=long_description,
+ long_description_content_type='text/x-rst',
license='GPLv3+',
keywords='collection inventory',
url='https://lesana.trueelena.org/lesana',
@@ -34,7 +45,13 @@ setup(
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Utilities',
],
+ project_urls={
+ 'Source': 'https://git.trueelena.org/cgit.cgi/software/lesana/',
+ 'Documentation': 'https://git.trueelena.org/cgit.cgi/software/lesana/tree/docs',
+ }
)