summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2020-09-16 12:16:57 +0200
committerElena ``of Valhalla'' Grandi <valhalla@trueelena.org>2020-09-16 12:16:57 +0200
commitc7b332764115de5c41a518c64ce902adc3b9b924 (patch)
tree8879cfadef9d644715a651b08a70a5e182551991 /setup.py
parent872b637d3144ce73c450691e122de1a4648231b6 (diff)
flake8 fixes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 7 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 72ac7ea..ffc79b9 100644
--- a/setup.py
+++ b/setup.py
@@ -12,19 +12,16 @@ setup(
version='0.5.1',
packages=find_packages(),
scripts=['scripts/lesana'],
-
package_data={
'': ['*.yaml']
- },
+ },
test_suite='tests',
-
install_requires=[
# 'xapian >= 1.4',
'ruamel.yaml',
'jinja2',
- ],
+ ],
python_requires='>=3',
-
# Metadata
author="Elena ``of Valhalla'' Grandi",
author_email='valhalla@trueelena.org',
@@ -39,7 +36,7 @@ setup(
'Environment :: Console',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',
- 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)', # noqa: E501
'Operating System :: POSIX',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: 3.5',
@@ -48,9 +45,10 @@ setup(
'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Utilities',
- ],
+ ],
project_urls={
'Source': 'https://git.trueelena.org/cgit.cgi/software/lesana/',
- 'Documentation': 'https://git.trueelena.org/cgit.cgi/software/lesana/tree/docs',
- }
+ 'Documentation':
+ 'https://git.trueelena.org/cgit.cgi/software/lesana/tree/docs',
+ },
)